Jump to content
Pikinik

perspective lock - tank becomes independant of view

Recommended Posts

I haven't had the issue since removing the dead tanks skin either. Maybe that is the culprit.

Share this post


Link to post
Share on other sites

Still having this issue, and it is game breaking... I almost want to uninstall all the mods because I have no idea what's causing it.

 

Here is as much detail as I can provide:

 

- has happened roughly 20 times out of roughly 200 games.

- Happens randomly, sometimes it won't happen for 40 games, sometimes 2 in a row.

- happens on all maps in all tanks I have played.

- usually happens 5-10 minutes into a match.

- almost always happens in sniper/arty view, I think it has only happened once or twice in regular view.

- moving the mouse and shooting will move the turret slightly and abruptly.

- sometimes if you try to drive while this happens the camera will get "suck" on a wall or rock or something. I once drove my T29 across a map using the mini map while my camera was stuck on a building, sometimes jumping abruptly to my tank if I had LOS on it.

- IF I am playing an SPG and it happens, switching from arty view to regular fixes it about 50% of the time. 25% of the time it will stay stuck in arty mode, 25% it will get stuck in regular mode.

- once after it happened I returned to the hanger and my mouse did not work. moving it and clicking it would make the pointer jump around the screen.

- Tried with and without aim mods, don't use spotting mods, happens on multiple crosshair mods, I almost wonder if it's the arty mod battle assist? . 

Share this post


Link to post
Share on other sites

All of this is happening to me as well.

 

1.) It started with CTD's crash to desk tops that would occur in the middle of the battle for no apparent reasons I could not tell why?

2.) it would happened about 12 times in one 3.5 hour gaming session.

3.) then the Zoom locked up when I was zoomed in on a tank, then I died (by the enemy team)-- blind.

4.) then the Turret began locking up, and the camera locked with it, I could not drive the tank, because the field of view was out of displacement. Tank would move out of field of view of the camera?

 

5.) I have re-down loaded the game client as of this evening, and redown-loaded the Aslian's mod pack, but the SAME thing is still happening.

 

All I know to do now is submit a ticket to Wargaming, and try to have them look at it.  Run the game Vanilla, and see if it happens again?

 

Some people on the NA forums are saying that it is happening to them regardless of not having any mods installed?  I will try to verify this if I can tomorrow....

 

My ticket will probably be in vain because Wargaming has habit of pointing the finger in other places when I turn in tickets.  But, i really wished they would work more closely with the mod makers to help aleviate some of this patch transition difficultly that they cause when they do a new patch.

Share this post


Link to post
Share on other sites

I am having what I think are same problems as OP. Only "sometimes" the view/game turret freezing in sniper mode. Not every game. Happened to me 3 times not. View stuck in zoom in max. unable to move turret or excape sniper view and return to arcade mode. Aiming reticle disappears. Cannot tell where gun aimed but can shoot. Reload and all give remains visible in the frozen view. Can drive tank but cannot view new position. This same thing first occured in 4.3.0 and again in now 4.3.4 Logs from 4.3.4 attached.

_Aslain_logs.zip

python.log

Share this post


Link to post
Share on other sites

Found this post from 4 months ago

 

http://forum.worldoftanks.com/index.php?/topic/407177-tank-stops-responding-but-not-lagpingfps-loss/

 

Turns out it is not even new, tho it would seem something has aggravated the issue since december.

 

That looks like a different bug, where you lose control of your tank's movements with the WASD keys.  With this bug, you can still control the tank via WASD just fine, but the turret and the aim point get stuck.  It behaves as if you're holding your mouse in the air--the buttons all work, but you can't point anywhere.

Share this post


Link to post
Share on other sites

the 1% white dead tanks inclueds white tracks when a tank has destroyed tracks...

this "white destroyed tracks"-mod causes problems since forever. 

Share this post


Link to post
Share on other sites

We need to make a list of issues and what was causing it for future sake... My memory is not that good :)

Share this post


Link to post
Share on other sites

So I have been having the same issue of camera lockup. As many of you have done, I spent time disabling and enabling each mod one at a time trying to find the cause. I kept having this issue until I switched to PMOD zoom. I then played 20 or so battles without an issue. Also I might mention a friend was having this issue as well, he remembered he did not have any issues when running your 4.3.0 modpack so he installed using that. He has now played nearly 100 battles in the last few days and has not had the issue.

Share this post


Link to post
Share on other sites

I'm running Aslain 4.3.4 and seem to get the perspective lock consistently in my Obj 286.

The most recent occurrence was this morning just after a JgPzE100 died next to me.

I think I was in sniper mode at the time. I would include logs, but I forgot to save them

before running a replay to analyze what happened.

 

The interesting thing is that I'm still able to move and auto-aim and was able to get another hit in.

Since I seem to get it repeatedly in my 286 I'll stick to my 704, which is arguably better ;-)

LBR

 

Update: No problems yesterday after removing white skins for dead tanks. (Keeping my fingers crossed).

Share this post


Link to post
Share on other sites

Yep removing the white tanks fixed it for me too. Had it happen in 2 out of 5 games, removed it after checking this thread, then played 30 without any issue.

Share this post


Link to post
Share on other sites

Played a 25 game session without white tanks installed and not a single zoom lockup. Before that it was about every 2-5 battles.

 

If white tanks were the problem I hope the creator fixes it soon as I do find that mod useful :)

Share this post


Link to post
Share on other sites

Has not recurred since I removed destroyed white tanks.

 

Notes: I tried various combinations of these and none addressed the problem

PMOD and other 30 zoom options

3 different gun sights including standard WG sight

different zoom levels

lowering graphics quality in game

playing without any zoom mod

auto-aim features

Share this post


Link to post
Share on other sites

It is several different mods not just one. Some report white dead tanks stops it, didn't help for me. I was able to trace my lock ups to outdated mods that are being relabeled as 9.7 ready. Searching for a good OTM reload marker I obtained a pack of mods containing 15 mods one of which was an OTM reload. Most of them can be traced back to one author, ZorroJ.

 

I have confirmed these 3 mods so far will produce the error almost every game, even multiple times in same game:

ZJ OTM Reload 

ZJ Contour Lines 

Shaytan Aimbot

 

http://pkwot.blogspot.com/2015/04/97-gox-cheat-pack-collection.html

 

Guess thats what I get for being curious and trying out forbidden mods. For now I'll just have to deal with the Lportii version (who is renowned maker of forbidden fashion) of the OTM reload.

  • Upvote 1

Share this post


Link to post
Share on other sites

Yup, you guys nailed it. White dead tanks have kept the problem from reoccuring for me. Maybe if they were pink dead tanks instead.........

Share this post


Link to post
Share on other sites

I'll take up votes for directing you all to turn off dead white tanks. Shameless, I know, but never hurts to ask for credit where credit is due   :D

  • Downvote 1

Share this post


Link to post
Share on other sites

Agreed. Froze over and over trying all combinations of crosshairs, Zooms, BalCalc & Battle Assistant off/on, installed/uninstalled.

Tried uninstalling WHITE DEAD TANKS.

Haven't frozen in over 40 games.

Share this post


Link to post
Share on other sites

Try now, I have updated White Skins and other dead skins, should be safe now. They are from totaly different source (author).

Share this post


Link to post
Share on other sites

Haven't had any issues since the updated White Skins from today (knock on wood).

Share this post


Link to post
Share on other sites

Sorry to say but with the 4.3.6 and white tanks enabled I got "locked"; non-responsive mouse movements and impossible to use arrows keys.

I will disable the white dead tanks-mod and hope for the best.

Share this post


Link to post
Share on other sites

Correction: I really did not use the white tank mod but got locked anyway. Perhaps enabling it will solve the problem :)

Share this post


Link to post
Share on other sites

I was not able to install 4.3.4. For some reason it kept freezing during install and timing out.

 

However, I was able to install 4.3.5. I have been using that for 2 days with white dead tanks off and I had no issues. I have not tried to update the modpack yet and turn that back on.

 

Hats off to everyone for posting and nailing it down.

 

 

Aslain - thank you for your hard work in continuing to make these modpacks and updating them for us.

Share this post


Link to post
Share on other sites

Repost from CBARoughneck:

 

 

Posted Yesterday, 05:45 AM

tonight i have been adding mods in one by one to find whats causing errors so far this is what i have found and right now i have no errors except the voip error and thats WG shit.

 

sights.pyc and sights.xml  example dmsword and any crosshair sight that uses these 2 files in scripts/client/mods   (JIMBOS works fine without errors)

 

ALL CONTOUR mods throw error after error  and makes your python log retarded long!!!!!!

 

battleassistant

 

avatarhandler zoom mods.  (NOTE PMOD zoom works fine without errors)

 

and XVM throws errors out as well even while running stand alone.

 

Can confirm the same through my own logs. The contour mod for example made my log over 50k lines of errors :o

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.