Jump to content
ThreeNill

Fonts, scaling or zoom issue

Recommended Posts

So I don't want to post this as a bug since I am pretty sure it's a problem "in my TV".

The issue - something has changed since 0.20.1.1 (the halloween patch) and since then text throughout the client has been "different" for the worse.

Here's a screenshot for example:



2017-10-30_23-45-19.thumb.jpg.9c4eac2b2bcc6684dcf916fff39913be.jpg

(You'll have to open it in full size)

So as you can see the text from the chat, minimap and damage taken panel seems normal. But the countour icons and damage panel seems out of order and hardy readable.

For comparison this is how the icons look when viewed in windows:

https://puu.sh/yb7em/88fa6de44f.png

 

And when you press Ctrl  + Scroll Down (once) they look exactly like in the client:

https://puu.sh/yb7ff/b937ad7a05.png

 

(P.S. I tried different countour icons, had the same issue)

 

I haven't touched any game settings or changed PC/Monitor etc.

And since the issue appeared I tried to tweak the interface scale in preferences.xml but nothing helped. Going from x0.9 to x1.33 in steps everything looks worse than x1.

So if anyone has an idea I'd greatly appreciate the help

 

 

Share this post


Link to post
Share on other sites

Weird that the patch would be messing that up... that seems weird... maybe something else changed on your computer at the same time, without you realizing?

 

On another note, the extra tier number on your contours can be fixed by removing the tick in this box:

contoursettings.png

Share this post


Link to post
Share on other sites

check If the program is running with override high dpi scaling enabled program>properties>compatibility>override high dpi scaling.

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks a lot @central . It is actually the case.
However I can't remove it. Some of the mods (and I only use the modpack) is setting it every time the game is ran.
Without mods the Compatibility is whatever I set it to (for example "Run as admin").
With mods it gets set to "Disable display scaling on high DPI settings" .  "Run as admin" is removed.
Any clue which mod/s would do that?

 

I have attached the logs if @Aslain or anybody else want to take a look.

 

Aslains_WoT_Logs.zip

Edited by ThreeNill

Share this post


Link to post
Share on other sites

I had the same issue only fix is to run without mods or else it rests every time you start program.

I personally got used to it on a 15.6 inch laptop 1920x1080 but if I using a higher end resolution laptop (like a mac or surface) the game would be impossible to play with the modpack.

I don't know which mod is causing this I'm surprised the problem has not been report by more people.

 

Share this post


Link to post
Share on other sites

@ThreeNill

 

Try without Battle Observer mod, I remember that mod author was messing up with screen in the past.

Share this post


Link to post
Share on other sites

I had the suspicion it could be the Max Farplane or any other of the more "graphics" mods. But will test it out tonight and post results. Worst case scenario I will try the mods one by one

Share this post


Link to post
Share on other sites

Unlikely, they are changing textures, not the screen settings, try to reset graphic settings if no help, don't run the game in window mode too.

Share this post


Link to post
Share on other sites

I found the culprit - it's XVM.

Tried with other random mods - it works fine.
With XVM:
Test 1 - default xvm team OTM
Test 2 - aslain's OTM
Test 3 - custom 6th sense icon
(all of the tests were exclusively that particular section only)


In all of the tests it was messing the Compatibility of the client.
On the bright side - XVM has the most extensive customization so I will dig into the configs later and try to figure it out.

Share this post


Link to post
Share on other sites

Really?... That's so bizarre.

 

XVM shouldn't at all be messing with that or affecting it at all... it doesn't mess with the exe file.

Share this post


Link to post
Share on other sites

I know but it's a fact, I can make a video to prove it :D

And I don't even know where to look in xvm. Nothing rings a bell that could affect it.
I know however when it appeared, so I can probably find xvm changelogs to get a clue.

Share this post


Link to post
Share on other sites

So I downloaded the default xvm from their website and the issue remains. So it's not Aslain's fault as the modpack is not causing it. I think I will try to take it up with them and hopefully someone pays me attention :D
guess this topic can be closed.
Thank you all for your time and @central for spotting the issue.

Share this post


Link to post
Share on other sites

I don't think I run Battle observer or any graphics mods.

I still don't get why so few people are reporting this anyone using a small high resolution screen cant read a thing in game with modpack running.  I guess very few gamers use these screens.

Share this post


Link to post
Share on other sites

I am running with a 24'' 1920x1080 native monitor (BenQ GL2460) . So it's not that - I had it running well before the halloween patch.

Share this post


Link to post
Share on other sites

in a 24" 1920x1080 it shouldn't be that small you should be able to get used to it after awhile.

what is the default windows settings? on my 15.6" 1080p it scales to 125% your 24" should be scaling a lot less.

Share this post


Link to post
Share on other sites

It's the default 100%. I had a talk with a dev from XVM, and managed to disable the Compatibility setting (Disable scaling blabla). However it didn't fix the issue. It's something about my system I am sure, but I can't figure out what..

Edited by ThreeNill

Share this post


Link to post
Share on other sites

The only odd thing beyond what has already been said (and crazy that XVM actually messes with the compatability settings...)

Is the fact that your screenshot, while it should be 1920x1080, is showing as 1918x1080.

Sounds insane though, if those 2 pixels in the width would be messing up the icons that badly.

Share this post


Link to post
Share on other sites

Nah that's probably me. I had to cut it in paint because it was a combined screenshot of both my monitors

Share this post


Link to post
Share on other sites

If your windows default settings are at 100% I would assume there would no high dpi scaling necessary which makes your issue really baffling.

Share this post


Link to post
Share on other sites

I feel I've given up. I just reinstalled the game, and created a new user on my windows (to void any AppData settings etc.) still same.

I feel like the players panel is not rendered to 100% (similarly to how you can zoom the map with "=" and "-" ).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×