Jump to content

WoT Modpack installer problem (v. - 11/29/2020)

Recommended Posts

I'm experiencing consistent problems on two systems installing the latest Aslain WoT Modpack (as of 11/28/2020). This has been an issue for many versions, over the past few  months, for me. I'm not sure if it's system specific (unlikely, given it's two systems), the mod pack itself or possibly the installer used to unpack the the mod pack. It could also involve AV or some other security issue that I haven't identified or worked around. Details follow:


System 1:

i7 9900k


1080 Ti

WoT installed on an Intel750 u.2 drive

BitDefender Internet Security 2020

7-Zip and WinRAR latest versions

W10 Pro up to date

Windows Defender disabled (also tried with it on)


System 2:

AMD 3950


Rtx 3900

WoT installed on Samsung m.2 drive

Kaspersky latest version

7-Zip and WinRAR latest versions

W10 Pro up to date

Windows Defender disabled/enabled


On running the installer I move through the install options (which is pulling in past settings from the .inf file in the same dir) and confirm. The installer sticks about 15% into unpacking on both systems and Tskmgr reports it being unresponsive. 


I've right-clicked the file and checked unblock.


I've right-clicked and set security/ownership perms on the install .exe.


I've tried turning Windows Defender back on and setting safe folders/files for WoT, install dir, downloads dir, .inf file, etc. No changes.


I've also tried on a completely new/vanilla WoT install in a new dir. 


I'd appreciate any advice anyone might offer on other steps to try to fix this. I've managed to get it to install previously after a looooooong wait but it shouldn't take 2+ hours, obviously, for a relatively small file and systems of this specification. This latest version is hanging entirely. Before anyone gets prickly, I'm not blaming the modpack file itself or assuming that's where the fault lies, although I have to recognize it's possible. Just looking for advice/suggestions or hopefully someone else who's resolved the same problem.




Link to comment

Hi I’ve had similar experiences with the latest mode packs. Especially with the anti virus, not ever before so much reports about Ransomware and blocking from downloading. Before you all start...no not blaming Aslain for the problems! Just letting you know that in my case I finally was able to find the problem, and fixt it by temporarily disabling Deep Guard. Just temporarily , don’t want any Ransomware on my computer.

Hope this info gives a bit of insight. Good luck.

All rights reserved    

Link to comment

Well, I finally found a semi-fix. I can get the new mod to install without any obvious issues or slowdown if I run the uninstaller on the last version and also fully re-configure the install options. Obviously, that takes a while and is inconvenient but at least the mod installs quickly now. I still don't know the cause, except it suggests the hang is due to existing mod files installed and perhaps some over-write permissions issue. Posting just in case it helps someone else in the future. You'll find the uninstall exe file in the Aslain folder under mods. Not sure if there's any way to copy the previous install .inf file into the new mod install .exe to save previous preferences (I'll try this on the next update) to save time but I went with a wholly clean install and reset all prefs.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.