Jump to content
Sign in to follow this  
Fiaze

Arty Mode stops working

Recommended Posts

Hello, 

 

Currently my arty mode has stopped working. I cannot press Shift to enter Arty view, nor can I press G. I have tried re-installing the mods to no avail. Arty mode works fine when I remove all mods.

 

 

Aslains_WoT_Logs.zip

Share this post


Link to post
Share on other sites

Cannot reproduce this, when I loaded same mods like you my shift key on arty works. Is it on all arties or just some?

Share this post


Link to post
Share on other sites

Seems it's intermittent. I reloaded all my mods after posting this, and it worked for a few hours. Just left to go to the gym, and reloaded my game and now it's doing it again. Running the log collector while in game...

 

I haven't tested other arties, I only have the Tier 8 GW Tiger P.

 

Attached log file was collected while in-game with broken shift.

Aslains_WoT_Logs.zip

Share this post


Link to post
Share on other sites

There is nothing conclusive in logs, they are basicaly error free. Maybe try to play without Arty aim possition mod.

Share this post


Link to post
Share on other sites

Just to test, after the previous game. I entered another game to see if it's game by game. Same tank, can't enter Arty mode. Arty Aim Position is working on regular map and mini-map.

 

Bought a Tier 3 Priest to test. Have not exited game yet. Arty mode does not work.

 

Logs after exiting above game. Will now remove Arty Aim Position mod and post again.

 

Aslains_WoT_Logs.zip

Removed "Artillery sight on the minimap"

 

Ran installer with following options. (Before, when it worked for a few hours, I had the first box checked.)

image.thumb.png.1b7f9f566c0ea6069d763974266d5955.png

 

Loaded into game on the Tier 3 Priest. Arty mode works. I don't consider this conclusive because reinstalling worked before. Will post if it breaks again. Attaching logs from being ingame in this Priest with arty mode working.

 

 

Aslains_WoT_Logs.zip

Share this post


Link to post
Share on other sites

Game worked all day yesterday. Just booted up my PC. First game in Arty, arty mode is not working.

 

Logs - Aslains_WoT_Logs.zip

 

Exited Game. Ran Data Integrity Check. No issues.

 

Went to re-run Aslains installer. Downloaded .13 newest version. Removed "Friendly arty aiming position". Deleted all previous mods and DLC's. Reinstalled.

 

Loaded into game. Arty works fine. Will update once it stops working.

 

 

Share this post


Link to post
Share on other sites

I see. Keep me posted.

Share this post


Link to post
Share on other sites

Played other games (not WoT) for 2-3 hours. Loaded back into WoT and Arty Mode does not work again. Exited game.

 

I have a feeling the game is modifying something when I exit the game, causing this to happen.

 

Launched game into safe mode. Loaded into game. Arty mode does not work in safe mode.

Logs after exiting game from safe mode - Aslains_WoT_Logs.zip

 

Ran Modpack installer again. Did not modify any settings. Loaded back into the game. Arty mode worked.

 

Exited game. Loaded back in. Arty mode does not work.

 

I think something is happening when the game closes.

 

Share this post


Link to post
Share on other sites

I've also noticed Shift stops working for normal tanks too. I have to manually zoom in.

 

I removed the SPG Assist mod option. Still testing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.