Jump to content
DJ Daemonix

"Yokosuka Barrier" port broken after restarting the game.

Recommended Posts

Posted (edited)

Greetings,

I'm encountering a bug where selecting the "Yokosuka Barrier" port in-game will work as intended in the scope of this running instance of WOWS, but after restarting the game, the port will revert back to "Philippines".

 

- Trying to select "Yokosuka Barrier" port again is impossible, as it appears already activated, just like "Philippines". So two enabled ports, somehow.

- Selecting another random port is possible, but current selected Port will read "Yokosuka Barrier".

- Selecting another port then selecting "Yokosuka Barrier" again is impossible, and will yield same result as 1st bullet point. ^

The only way to clear the bug is to restart the game once more. Only then is "Yokosuka Barrier" selectable again, and usable, but next restart will yield the same result, if selected.

Regards,
DJ Daemonix

Aslains_WoWs_Logs.zip

Edited by DJ Daemonix
Obligatory Logs attached, sorry for the omission.

Share this post


Link to post
Share on other sites

A bit more on the topic, Yokosuka Barrier's skybox is completely broken

 

Share this post


Link to post
Share on other sites

1./ Before exit the game, u must switch back to Official ports, any of them

 

2./ If u forget and it will stuck with Official ports << WG's fault, I reported it but they didnt fix.

to fix it >> open "preferences.xml" find the Green tags and change the current (port_preset & port_preset_custom) like Orange tags,

follow this >>

Quote

<lobby_values>
            <port_preset>    ocean    </port_preset>
            <port_preset_custom />

            <i_dont_like_premium_port>    false    </i_dont_like_premium_port>
            <i_dont_like_twitch_port>    false    </i_dont_like_twitch_port>
            <i_dont_like_azurlane_port>    true    </i_dont_like_azurlane_port>
            <i_dont_like_arc_port>    true    </i_dont_like_arc_port>
            <game_type>    PVEBattle    </game_type>
            <ship>    4286527472    </ship>
            <shipBattleHistory>    4184749872,1561265148,4183701456,1561265623    </shipBattleHistory>
 </lobby_values>

  • Upvote 1

Share this post


Link to post
Share on other sites
Quote

<port_preset_custom />

 

You sure that / is in the right place, mate?
Generally / means ignore or end the following, which means the > would be ignored, resulting in port_preset_custom not being recognised. I have no experience with this API whatsoever, so this could be a completely idiotic misassociation made in ignorance of the preference.xml syntax, in which case I apologise.

 

Share this post


Link to post
Share on other sites
13 hours ago, FuneraVirtus said:

 

You sure that / is in the right place, mate?
 

 

it will remove Custom port and return to official one

Share this post


Link to post
Share on other sites
23 hours ago, FuneraVirtus said:

 

You sure that / is in the right place, mate?
Generally / means ignore or end the following, which means the > would be ignored, resulting in port_preset_custom not being recognised. I have no experience with this API whatsoever, so this could be a completely idiotic misassociation made in ignorance of the preference.xml syntax, in which case I apologise.

 

My thoughts exactly.

As i work with XAML frequently, i'm very used to that sort of syntax. To clarify, a / in an orphan tag is used as an escape character, to specify its orphancy. Reason why HTML has <br/> tags to end line.
So perhaps something broke withing the preferences.xml file upon install of the modpack, but there is no way to know without confirmation from Aslain himself. I'd be glad to attach my preferences.xml file for reference, had it not contained my connection strings and tokens used for logging into my account.

Still, the problem can't just be worked around. We need a fix on this.

  • Like 2

Share this post


Link to post
Share on other sites
6 minutes ago, DJ Daemonix said:


So perhaps something broke withing the preferences.xml file upon install of the modpack, but there is no way to know without confirmation from Aslain himself. I'd be glad to attach my preferences.xml file for reference, had it not contained my connection strings and tokens used for logging into my account.

Still, the problem can't just be worked around. We need a fix on this. 

Modpack is fine

Port mod is OK

just because WG didnt fix it since 0.8.4

  • Upvote 2

Share this post


Link to post
Share on other sites
Posted (edited)
21 hours ago, MixCore said:

it will remove Custom port and return to official one


Thank you for the clarification; I have changed it as you said.  :glasses:
However, under the /Bin64 folder, I found another  preferences.xml file, with different  information, including this :
 

<lobby_values>
            <port_preset>    ocean    </port_preset>
            <port_preset_custom />
            <i_dont_like_premium_port>    true    </i_dont_like_premium_port>
            <i_dont_like_twitch_port>    false    </i_dont_like_twitch_port>
            <i_dont_like_azurlane_port>    true    </i_dont_like_azurlane_port>
            <i_dont_like_arc_port>    false    </i_dont_like_arc_port>
            <port_preset_custom>    Black_Hole    </port_preset_custom>

 

My question is:  Should I remove   <port_preset_custom>  Black_Hole  </port_preset_custom>  from that file, or is your orphan tag solution designed only to empty  the value of port_preset_custom before  the client tries to set it to the user's port choice?
The reason I ask is that I'm wondering whether I need to search my computers for any other prefrences.xml files tied to WoWS installations (Public Test, for example) and remove the custom port line from them all.

Edited by FuneraVirtus
grammar
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, FuneraVirtus said:


Thank you for the clarification; I have changed it as you said.  :glasses:
However, under the /Bin64 folder, I found another  preferences.xml file, with different  information, including this :
 

 

My question is:  Should I remove   <port_preset_custom>  Black_Hole  </port_preset_custom>  from that file, or is your orphan tag solution designed only to empty  the value of port_preset_custom before  the client tries to set it to the user's port choice?
The reason I ask is that I'm wondering whether I need to search my computers for any other prefrences.xml files tied to WoWS installations (Public Test, for example) and remove the custom port line from them all.

"<port_preset_custom>  Black_Hole  </port_preset_custom>"

yes, remove "Black_Hole" then it should be back to normal

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.