Jump to content
Sign in to follow this  
krazygluon

Calling All Linux Users

Recommended Posts

Fellow Penguin Tankers,

    Your experience may vary, but I'm pretty happy that WoT (~95%) and Aslain's (~90%) work so well for me in Linux (Manjaro + Lutris)

 

But I can't help but want to make that other 5-10% of the functionality work.

 

DISCLAIMER: I am not asking for support from Aslain or WG or for changes to be made to WoT or the Modpack to accomodate linux.  I am only asking to create an ongoing discussion of what doesn't work and how (using only what we can do to Linux and the config files / mods / etc after release) we can make it work with linux.

 

So I'd like to start a discussion.  Please reply with: Distro, Wine-method (vanilla/PlayOnLinux/Lutris/etc), GPU (AMD/Nvidia) and what doesn't work about Aslain's mod for you.  If you fixed it, let us know how.  If you had an issue someone else brought up, but fixed it, let us know how.

 

So that said, I'll start with a few:

In all cases, I run the aslain's installer via lutris via "run an exe inside wine prefix" side command.

1: Manjaro/Lutris/Nvidia - After clicking next after selecting the install directory, I get a "An error occured! Unknown method" dialog.  Appears harmless but may relate to other install issues.

2: Manjaro/Lutris/Nvidia - After completing an install, I get the following error "Exception EAccessViolation in module Aslains_Wot_Modpack_Installer_v.1.9.0.3_06.tmp at 021F2E38.  Access violation at address 021F3E38. Write of address 021F3E38."  Appears harmless but may relate to other install issues.  Memory address changes with every iteration.  Interestingly this only appears if I install anything other than the Aslain's choices setup.

3: Manjaro/Lutris/Nvidia - Custom Contour Icons never show up, no matter what icon set.  I tried a different modpack and this was not a problem.  So it's definitely nothing inherently wrong with linux and CCI's but rather with Linux and the Aslain's process for installing CCI's.  Issues 1 and 2 may relate.

Inspection of files in the CCI .7z file and files installed in the res_mods directory shows that the files never make it.  This indicates the 7zip process being used by the Aslain installer is not working as intended.  I tried to use the custom install folder and the cached .7z from the DL cache.  Just dropping it in doesn't work.  extracting then re-zipping as .zip doesn't seem to work.  Manually installing absolutely works.

4: Manjaro/Lutris/Nvidia - Aslain colored tech tree icons don't show up.  Same T/S as #3, manual install from DL cache works fine.

 

Again, not asking for support, more looking to build a knowledge base and help linux users bootstrap their way towards making what we get work with what we have.

 

But I will say, if we could get some insight into how .7z files are processed into the res_mods folder, this would help as this seems to be one of the biggest hurdles.

 

Share this post


Link to post
Share on other sites

The installer will download the 7z to c:\Games\World_of_Tanks_NA\Aslains_DLC_cache\ (path might change in your case). Then the installer will unpack it from this location to res_mods and mods, usually to version folder. Then in the end these batch scripts (_Aslains_movetree_mods.bat _Aslains_movetree_res_mods.bat ) will try to move all files from version folder to real verion folder (atm. it will be from version to 1.9.0.3).  Looks like your linux cannot execute them properly, so the 7z are unpacked to the version folder, the batch script will fail on moving them to 1.9.0.3 and in the end the installer will wipe out version folder and you will end up without all the mods that are distributed as 7z.

Share this post


Link to post
Share on other sites

Ok, I've been over the bat files and don't see why mods install fine but res_mods don't.

 

But I did a contour icon only install from a clean installation, and noticed something interesting: https://i.imgur.com/toIgc63.png

It looks like the script is creating the right files for witblitz icons, but doing it a level down (straight into the res_mods folder instead of the 1.9.0.3 folder.  It's worth noting that those folders are created, but empty (no files transferred)

 

I'm also attaching my log files.  From what I can tell, the installer thinks it has done everything right.

_Aslains_Installer_CompList.log _Aslains_Installer_Extractor.log _Aslains_Installer.log _Aslains_movetree_command_res_mods.log

Share this post


Link to post
Share on other sites

Manjaro, NVidia Gtx 660
Wows and mods installed through lutris

Same 1&2 errors as OP
Installer claims that no game client is recognized although almost all mods install correctly

Icons from info panels, self and enemy, and icons from side panels are missing.
https://cdn.discordapp.com/attachments/477424933656461322/717339877435375666/unknown.png

Torpedo warning sounds do not work

Once, i had an issue with fonts, where all characters in the game client turned from english to question marks but that got resolved a few modpack updates later.
I believe the font.zip was failing to either extract or move the fonts to their proper location.

Side comment:
The dev of wows-monitor mod was kind enough to provide me with a native executable for linux!
We had a talk about him supporting major linux distros but he claimed there was only 1 person using his mod in linux.
He requested that if i ever find more people using linux in need of his mod to send them over to his discord: https://discord.gg/Tds7WBs so i shamelessly leave this here :P

Share this post


Link to post
Share on other sites

Ubuntu 18.04.4, Nvidia GTX 2080
WoWs installed through steam, using proton-ge-custom 5.8-GE-2-MF
Aslain mod installer run with wine 5.0

I have the same issues as OP too, and the issue with missing icon from info panels, self, enemy, etc, as bald is mentioning in the previous post

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.