Jump to content

zeiss mod incorrect zoom?

Recommended Posts

hey aslain,


if you can, would you please take a look at zeiss' zoom out mod(or throw the author a line)? it works well, however i think he messed up the zoom values or something. up until now i used extreme client x15 (yes, i find the standard zoom a bit much :P), but since the last update, it's an extremely small zoom even for me. i haven't attached logs, since there's not an installer issue, but i have attached screenshots with the pre-update extreme client x15, and screenshots with all the ones post update. you can clearly see the difference if you look at the range numbers.

(the extreme client with no magnification number has the description of standard zoom, but you can clearly see it's nowhere near as magnified as vanilla. (though not sure if this is since the patch or was there before))


edit: nevermind, attaching logs as well. not sure how/why, reinstalled the pack without the zeiss mod selected, and the game worked well, until my interface froze. i could still move the ship around, but my camera remained in the same position, the turrets wouldn't turn, and the minimap was partly frozen (ship icons wouldn't move around, but they would change state if killed. caps worked as well. yes, that's my ship next to the island. as you can see, i had half health left. in port, ships wouldn't show up, i couldn't move the camera around, it even wouldn't jump to container ship and i couldn't exit the game even though the menu appeared when pressing the buttons. i doubt it's connected with zeiss, but i can't say for certain. what i can say for certain is that the reinstallation was done with the delete previous mods and delete cache). unfortunately, the logs are not from that reinstallation, i reapplied the zeiss mod before i realised that i should have saved the logs :( ah well, hope they can still show if anything's wrong.






extreme x15.jpg

extreme x25.jpg

extreme.jpgzoom pre patch 2.jpgzoom pre patch 1.jpg

interface stuck 2.jpg

interface stuck1.jpg

interface stuck - port.jpg



Edited by Aslain
added spoiler tags for images
Link to comment

take ur time, no rush, knowing there's a possible fix on the horizon is quite enough for now :D


btw, completely unrelated, i noticed the modpack takes increasingly long to start once i doubleclick the executable (it's around 30 sec->1 min now). it is something on my end, or it something to be expected?


later edit: ok, tested the new release, and the zoom modifiers are still messed up. x25 is identical with vanilla zoom, when it was supposed to be an increased magnification over vanilla. i should have asked, does everyone else have the proper zooms, or the same as me?

Edited by cosmo
Link to comment

allright, in case anyone else has the same issue as me, this is how i managed to fix it:


open res_mods/(version)/cameraConsumer.xml

near the end of the file, you will find this sequence:



change line  <zoom>15</zoom> to  <zoom>20</zoom>  (for the current version,, it's line 896) (it's the first sequence of all the zooms available)

don't ask me why 20 works as 15 before, but that's how it is. proof of zoom with the abovementioned modification is attached.

hope this helps others like me :D


i assume you can use this method to setup whatever zoom level you desire. happy sailing!



Edited by cosmo
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.