Jump to content

Locks up at battle loading sometimes

Recommended Posts

I have no idea which mod is causing this.  I have tried various things but still have the issue.  As the title says it locks up at the battle loading screen, sometimes.  Most of the time it works fine, but tonight it locked twice out of twenty battles.  I then Alt-F4 it, reload and it works fine for a while.  It has been doing this on and off for weeks now.


These are the last lines of my python.log file when it is locked up.  I don't know what the "battle_control" is, or what mod it is from.  Any tips or suggestions would be helpful.



2018-11-21 21:27:54.858: INFO: [WL] Whitelist update started...
2018-11-21 21:27:54.858: INFO: [WL] Whitelist update finished.
2018-11-21 21:28:47.401: INFO: [gui.Scaleform.app_factory] Creating app: scaleform/battle
2018-11-21 21:28:47.761: NOTICE: [NOTE] (scripts/common/debug_utils.py, 251): [SPACE] Loading space: spaces/37_caucasus
2018-11-21 21:28:47.951: INFO: [gui.app_loader.loader] Space is changed: LobbySpace() -> BattleLoadingSpace()
2018-11-21 21:28:47.951: INFO: [gui.Scaleform.app_factory] Destroying app: scaleform/lobby
2018-11-21 21:28:47.978: INFO: [gui.app_loader.loader] App is destroyed: scaleform/lobby
2018-11-21 21:28:48.215: INFO: [pika.adapters.base_connection] Connecting to
2018-11-21 21:28:48.216: INFO: [gui.app_loader.loader] App is initializing: scaleform/battle
2018-11-21 21:28:48.490: INFO: [gui.app_loader.loader] App is initialized: scaleform/battle
2018-11-21 21:28:49.319: INFO: [gui.app_loader.loader] Space is updated: BattleLoadingSpace()
2018-11-21 21:28:49.908: WARNING: [gui.Scaleform.framework.entities.BaseDAAPIComponent] Class with alias `teamBasesPanel` already registered in object ClassicPage[0x52c31910]=[key=ViewKey[alias=classicBattlePage, name=classicBattlePage], scope=SimpleScope[0x2160d970]=[scopeType=view, parentScope=GlobalScope[0x2160d930]=[scopeType=global, parentScope=None]], state=2]. It will be rewritten.
2018-11-21 21:28:54.065: ERROR: Traceback (most recent call last):
2018-11-21 21:28:54.065: ERROR: File "scripts/client/gui/battle_control/arena_info/listeners.py", line 518, in __loadCompleteDelayed
2018-11-21 21:28:54.065: ERROR: File "scripts/client/gui/battle_control/arena_info/listeners.py", line 578, in __onSpaceLoadCompleted
2018-11-21 21:28:54.065: ERROR: File "scripts/client/gui/battle_control/arena_info/listeners.py", line 102, in _invokeListenersMethod
2018-11-21 21:28:54.065: ERROR: File "scripts/client/gui/battle_control/controllers/arena_load_ctrl.py", line 57, in spaceLoadCompleted
2018-11-21 21:28:54.065: ERROR: File "scripts/client/Avatar.py", line 804, in onSpaceLoaded
2018-11-21 21:28:54.065: ERROR: File "scripts/client/Avatar.py", line 2951, in __onInitStepCompleted
2018-11-21 21:28:54.065: ERROR: File "mod_atac101obf", line 1, in iiiii
2018-11-21 21:28:54.065: ERROR: File "mod_atac101obf", line 1, in IiiiIi1I
2018-11-21 21:28:54.065: ERROR: File "mod_atac101obf", line 1, in iI
2018-11-21 21:28:54.065: ERROR: TypeError: 'NoneType' object has no attribute '__getitem__'


python - Copy (3).log

Edited by FullTank
Link to comment

same thing happening to me...  this started about Nov 21, or after MOD update release 7.11.0    I will try alt F4,  as I could not find any key of mouse click combinations to exit.

  If you find a solution... let me know on this post...  I can only go out of game and log back in... this gets me back in the game (most of the time)... but by then battle is about ended.

Link to comment

Follow up info:   I have removed the res_mods file and folders and ran the game without MODS... If works fine and never had this problem... reinstalled MODs and it started again... 

this morning I played 1 game fine, next game (random) locked up after waiting to get into a game and the 30 - 40 second count down... I can still use the 4 taps at top, to change from Team Information, Tips, battle screen, and division stuff, so it is not locked up, just never goes into the battle screen, I can hear the sound of battle and can even go to the tab of the battle screen (mini map like) and see the ships moving, so I know game is running with out me in it...  

    have rebooted my computer, reloaded game and still happens, two times in a row this last time and got a "inactivity in battle" warning for WOW.


  Need a solution to this... as I hate to play without the MODs anymore.. like it a lot better using these...  please help if you can.

inactivity in battle 11-24.PNG

Link to comment

I have quite a few MODs also... and it is going to be hard trying to remove one, play the game and see if that is it, as it doesn't happen all the time...  I deleted the res_mods folder, and reloaded the latest MOD, (same one I was using), and it did not mess up one time in about 15 - 20 games today.   So FullTank, you are going to have your hands full trying to figure this one out.


   This was to be happening to others as well... my grandson said it is happening to his games also, but he has his account on my computer, so I was thinking it could be my computer or something running from time to time causing it to glitch...    Also, on these games that worked today, I have to say that I did not do any keystrokes, mouse-clicks, and such while I was on the loading screen, thinking that something I was doing was messing it up, and since it did not mess up, I will continue to just look and not touch while game loads...


   Keep me informed of your progress...  

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.