Jump to content

V 19.14-20 Problems downloading

Recommended Posts

Trying to update/install the latest client version 20. When clicking any link from the downloads tab for v9.14.20 , (Blue link, mirror 1 or direct) it opens a window in second tab like normal. However where the download box is the title of the version there but no box or anything to click on to start the download.


I've check to make sure I'm using the latest browser, (Google Chrome and Internet Explorer). I tried to go through the website manually, restart browser and even restarted the computer, like that was going to help. 


First time having this problems, not really sure how to proceed.


Attached is a screenshot of what I'm looking at.


Link to comment

Just installed the lastest mod pack update for WoT, for some reason I can't enter the battle as the game freezes during the battle loading screen. I've tried using other mods and have no problems entering the game, but, with this new updated modpack, for some reason, I can't enter the game. (Please note that I love this modpack and use it all the time, I do hope you can solve this issue.) 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.