Jump to content
ITKAMIKAZED

FPS drops(microstuttering) when modpack installed

Recommended Posts

Hello, posted yesteday on discord but i will explain it again.

 

Firstly i got problems with not creating mod config file. I found that it probably caused combination of XVM Map (your settings + circle HP bars on minimap) + HD minimap overlays (tactical and ALT heatmap + contour map icons) XVM map was not working at all and probably caused not saving modpack config file. I Tried then mod by mod deselecting and fresh install and now it finally saving config properly. I have old config file that was last saved, before it stops working.

 

Now issue is my actual combination, where IDK what mod/s is causing conflicts and microstuttering. Vanilla game runs butterry smooth at like 120-144 fps. Now i can drop like 50-90 fps next is 144/130 and again 50-90. Sometimes it crashed game, xvm autocrashlog collected some files but idk where it stores. I will upload it if u tell me what more u will need.

Also, sometimes id did not load XVM (map was working) or XVM Map (XVM was working). Also sometimes after few minutes (usually after i die) in battle it dont show modded colored messages but original/bugged with more spaces between. And last minor - idk what mod causes sometimes me typing random sentences :D (not meaning i was spotted or reloading time) probabbly radial menu or idk.

My PC specs:

CPU: Ryzen 7 1700x stock speeds, watercooled and game temps about 55c

RAM: 2*8GB HyperX Predator 3333MHz CL16-18s

GPU: Nvidia GTX 1080 Ti

Windows 10 Pro 1803 (latest security updates)

System on 240GB SSD, Game on 6TB WD Blue HDD (no problems at all, new drive and no ms delays as i look in taskmanager at drive when game and no stucks in loads)

 

And thanks for your time! I appreciate your hard work on mods :)

Aslains_WoT_Logs.zip

wotmicrostutter.PNG

_Aslains_Installer_Options-old-before-bug.inf

Edited by ITKAMIKAZED
added old config + windows version

Share this post


Link to post
Share on other sites

Try without two mods, hangman hangar manager and Friends Notifier.

 

Start with Friends Notifier, and let me know if it helped, follow up with the other one if no help.

Share this post


Link to post
Share on other sites

Yeah, without friends notifier its better but still not stable like vanilla wot, even i notice i cant reach 144 but im sitting around 90-120 sometimes 80 or 120.

Now gpu usage looks like this (himmelsdorf):

image.png.55997a23a6de7516fe4ea9fee75d30e0.png

Well next map Mountain Pass looks this:

image.png.bdc7a7b9b35c7f9d3b97ba2e85044d79.png

Soo still not OK and i was getting 60-70/90-110 fps. Now have lower CPU usage. Looks like modpack is broking WoT new rendering engine, and running on old? Before it runs at 12 threads now at 7 or 8. :/

Will update how well runs without hangman. Thanks for these tips :)

Share this post


Link to post
Share on other sites

With mods it never be like in vanilla. Mods like XVM can eat up some fps.

Share this post


Link to post
Share on other sites

reffering to threads used while game - there can be fps drops bcs it brokes new rendering engine?

Share this post


Link to post
Share on other sites

Well, there is also chance for this. 

Share this post


Link to post
Share on other sites

It's funny this was brought up, I have been having the same issues, I think I will try without friend notifier and see if that's what it is for me. But I noticed its at it's worst when I'm around forested areas, Not seeing my FPS drop but micro stuttering like crazy also with a few crashes.

Share this post


Link to post
Share on other sites

Well, same settings as posted up only without friends notifier: After few hours of playing game started crashing firstly like after 2-3 battles, then after each and finally 2 or 3 times per battle! :/ So i uninstalled modpack, cleaned with mod cleaner and come from scratch.

Now i tried installing with your modpack selection - game fps is almost vanilla OK BUT game crashed in hangar when looking around tank, with skirmishes clan battle active on top(picking tanks).

I hope that crash in hangar will not be so frequent so I added few mods from old selection. Without friend notifier, hangman and few more.

 

And when installing with LOADINF_for_Aslains_Installer.exe - it dont create _Aslains_Installer_Options.inf again :/ Hopefully,after next install (normal), it somehow manage to know what i picked even WITHOUT that config file?? But where is it stored then???

Share this post


Link to post
Share on other sites

These may be eating your fps and/or causing stutters

No need to reinstall, just move the files out of the mods directory and try the game. 


09.02.2019  17:55    <DIR>          DZD

09.08.2018  22:05           648 090 colored_stickers_byVlad_cs_sr_1.0.wotmod
06.05.2018  19:12        27 962 748 goldvisibility.color.wotmod
13.10.2018  09:21        10 637 656 goldvisibility.core.wotmod
06.02.2019  11:02             5 267 lagindicator_ball.wotmod
04.02.2019  02:30            35 741 minimap_guns.wotmod

 

My bet is on minimap guns

  • Upvote 1

Share this post


Link to post
Share on other sites

about that minimap guns, i found that its probably OLD version...  comes to updated RU site where is this mod for 1.4 but have different files + have mod_minimap_tankview.json but this from modpack seems to be only one file. I want this mod so i will try from that RU site if its better. Also that gold visibility mod is great as i can see any gold player by this. Colored stickers seems fine, Aslain have it and when i tried only his settings it was definitively OK.

image.png.73a62f40fe07404d95e06741c2d4dfdb.png

 

Also Aslain, yesterday evening on discord #general-wot said Mirukii that eh runs hangman with 0 problems and also tried friend notifier and have same 0 lags or microstutter. I wonder what mod can conflict here.

+ shoot blocker on friends/destroyed (same u have in your config) dont work. IDK what can conflict this, jimbos mod or xvm settings for aim/bullet time etc .. :/

Share this post


Link to post
Share on other sites

I am using safe version from different author, you cannot compare dates of two different mods, you posted link to mod from ekspoint, his mods are infected with adware and trojans. I will remove links.

  • Upvote 2

Share this post


Link to post
Share on other sites

oh i am sorry, dont know that. Hopefully i did not yet installed it. :O
I only tried to remove lagindicator and yours minimap_guns - game runs almost OK, some minor microlags but definitively better. Yet, i got again crash from XVM probably, as i read other post from Hard_As_Iron - hopefully they will fix it asap.

Next tried with minimaps_guns - seems OK still. So i will clean install it, just in case it can reduce amount of crashes.

 

 

Also i wonder, when i uninstalled modpack, in game folder there is left few mods or settings. When i did not remove it with mod cleaner, i got really really frequent crashes. Why you by default dont include that left files to remove? I was really wonder why game crashed so many times when i tried to uninstall it completely and look for that mod cleaner program - found many files left:

 

Share this post


Link to post
Share on other sites
1 hour ago, Aslain said:

you posted link to mod from ekspoint, his mods are infected with adware and trojans. I will remove links.

i just looked into new version of modpack #07 and still, under mod is link to that, by your words malicious RU mod, well u plan to keep it here or? Just in case u didnt know it, anyone then can infect his computer if didnt know this.

image.png.a5d05109e1e0052403ce963f3ff9af99.png

Edited by ITKAMIKAZED
  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.