Jump to content
Suralin

1 in 10 Games Don't Load, how to troubleshoot which mod would cause this?

Recommended Posts

I'm not sure if anyone's encountered this or why, but I'll randomly not load a battle and the only fix is to force quit and start the game back up to join the battle.  Since this doesn't happen all the time (maybe 1 in every 10 games), I can't exactly troubleshoot by just turning off the mods one by one.  So I was wondering if anyone already has an idea or might know how to troubleshoot this?

 

I've attached the Logs, but here's the comp list to avoid downloading the zip itself:

 

Selected components:
      ----------------------[ Ship Contour Icons [DLC] ]------------------------------------
         by ThatsNumberWang
         Player's Panel mod
            Player's Panel with HP bars normal (config by atmaxx)
      Gun marker shapes
         marker #3
      ----------------------[ Over Target Markers (OTM) ]--------------------------------
         version by BADoBEST
            BADoBEST: HP + nick
      ---------------------[ Mods sharing hud_lib.swf file ]------------------------------
         Battle GUI customization
            Detection icons
               sixth sense Colored Icons
            Target Lock Markers
               Target Lock Markers: Aqua
            Compass Elements
               shape 2
            Torpedo Warning
               torpedo warning v5
            Ribbon Badges
               Ribbons v3
      ----------------------[ The Minimap mods ]----------------------------------------
         Minimap images
            minimap by autospy
      ---------------------------[ Port appearance ]------------------------------------------
         Night Dragon [DLC]
      ------------------------[ Loading screen ]-----------------------------------
         Battleships (by Mebius_LW)
      Tracers
         No Shell Contrails (by MREBoy)
         Colored extended tracers (by atmaxx)
      Cruise control
         More visible cruise control (by Mebius_LW)
      Chat
         Improved Chat (Displays ship name in brackets)
      Achievments
         Transparent unobtained achievments (by Roktaal)
      FPS Limiter
         144
      ----------------------[ Commander Crew appearance ]-------------------------------
         Kancolle’s admiral commanders (by Xandier59)
      --------------------------[ Sound mods [DLC] ]--------------------------------------
         Torpedo Warning Voice
            torpedo warning: Imperial Alert Siren Sound (by MajorRenegade)
      -------------------------[ Various mods ]---------------------------------
         Session Stats
         Better ship icons on compact carousel
         Ship Name Romanization
            with lady commander name
         More visible torpedoes in water & gun hits splash [DLC]
            Blue style
         Navigator (ship direction indicator)
            Navigator: original
         Clear Vision (by MajorRenegade)
         Alternative Ship HP bar indicator above compass (by AutoSpy)
         Kancolle’s rank icons (by sudoku135)
         Running Lights
         Enable ability to record battle replays

Additional tasks:
      Installation type
         Clean install (clean up res_mods folder - RECOMMENDED!)

 

_Aslain_logs.zip

Share this post


Link to post
Share on other sites

Maybe try without some mods like Navigator, it used to crash the game in the past.

Share this post


Link to post
Share on other sites

I have this problem too but i am not sure it has to  do with asain modpack.

 

Also the link to the mod site for the new mod "Display consumables" from within the alsain installer is redirecting me to aslain site which is probably wrong except if i have understood wrong.

 

Regards.

Share this post


Link to post
Share on other sites
On 11/27/2016 at 4:55 AM, Aslain said:

Maybe try without some mods like Navigator, it used to crash the game in the past.

It's not exactly crashing, though.  It just stays on the Loading battle screen, with "Awaiting Players..." never changing.  I'll try to remove the Navigator and see if I continue to get it.

Share this post


Link to post
Share on other sites

I just finished watching the new patch video on the wows website.. and was checking out the comments.. and you're not the only one.. I am having the issue too.. but from the comment.. it's a warships bug.. not modpack

  • Upvote 1

Share this post


Link to post
Share on other sites

I have this issue as well. Like you say it's tough to sort out. I've looked at the python.log file but that doesn't do much to narrow down the issue. It helps me a lot more when the game outright crashes mid-battle because generally the last line of the log contains an error message that describes the problem. But this time, it just looks like it was loading and then just paused and never actually completes.

 

So here's what I usually run. Perhaps we can narrow down commonalities.

 

  • Hakabase historical contour icons
  • BADoBEST v2 side panels ("ears")
  • Old class panel with hp bars (so glad this came back! I do not like the new one at all)
  • Dynamic nomogram crosshair (hang issue precedes switching to this)
  • Gun marker shape no. 6 (these should just be texture files)
  • Blue range finder
  • Zeiss Zoom Sniper x25 (this is just an .xml and shouldn't cause hangs)
  • BADoBEST Percent+nick
  • Ship Movement Indicator
  • MonstroMarkers
  • "Black Citadel" v4 Chain detection markers (graphics files only)
  • Hits marker 2 (graphics file only)
  • Autospy minimap with custom circles and larger ship names (I'll probably remove the enlarged names soon)
  • Session Stats
  • Extended Tech Tree (this is just an .xml file set)
  • Clear Vision (this is just an .xml file)
  • AEGIS tracers (Aslain calls these "main guns: lines" and "anti-aircraft guns: lines")
  • Hide Fire Screen
  • Alternate ship HP bar
  • Radio location: white with red triangle (never tested this; don't own ships with RDF. Probably just a texture file)
  • Move ribbons to center (I think this is just an xml file tweak)
  • Smoke indicator (not in the Navigator section)
  • Transparent unobtained achievements (graphics files only)
  • Golden premium consumable icons (graphics files only)
  • Mouse pointers
  • Enemy/self info panels
  • Detailed damage indicator
  • Companion
  • Compact quick commands (don't know how to activate this yet!)
  • Improved chat v3
  • Disable soot/burning effects
  • Fog remover
  • Anti-glare
  • Training room enable
  • Replay enable

... and I think that's it. What do you share with me?

Share this post


Link to post
Share on other sites
25 minutes ago, Buran said:

I have this issue as well. Like you say it's tough to sort out. I've looked at the python.log file but that doesn't do much to narrow down the issue. It helps me a lot more when the game outright crashes mid-battle because generally the last line of the log contains an error message that describes the problem. But this time, it just looks like it was loading and then just paused and never actually completes.

 

So here's what I usually run. Perhaps we can narrow down commonalities.

... and I think that's it. What do you share with me?

See my signature on how to create the logs zip, and attach that :)

Share this post


Link to post
Share on other sites

Sure! I'll do that this evening (or, failing that, this weekend) as I'm not on my gaming system right now. I'd rather send logs from the system I actually use to play, not the ancient one I'm just using right now to respec captains.

Share this post


Link to post
Share on other sites
Just now, Buran said:

Sure! I'll do that this evening (or, failing that, this weekend) as I'm not on my gaming system right now. I'd rather send logs from the system I actually use to play, not the ancient one I'm just using right now to respec captains.

Sounds good :)

It makes it much much easier to try your setup, and also see possible errors in logs and what not.

(One of the files included will be the exact mod setup you use :) without the need to type out your list, and manually adding them one by one)

Share this post


Link to post
Share on other sites

I had this issue too.. Did you by chance happen to come across a post on the ships offical forums about 'increasing' or 'stabilizing' frame rate?? There are a few posts later on in that topic about how one of the changes causes games to not fully load.. I stopped doing that one change and I didnt have the issue anymore.

Share this post


Link to post
Share on other sites

Here's my log file. :) Latest/current mod mix. Strangely the installer seems to forget my selection of the Hakabase historical ship icons but that's a glitch with the installer, not the icons. I'll manually add them but the log will not reflect their existence.

 

Aslains_WoWs_Logs.zip

python.log

Edited by Buran
Updating to a new log file - added Python log from after a failure to load

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.