Jump to content

Contour Icons not showing

Recommended Posts

Good evening,


I've encountered an issue a few days ago while installing aslain's modpack, and to be more specific, i had problems with contour icons missing. After a little searching i found out that iconset.xc file in World_of_Tanks\res_mods\configs\xvm\Aslain folder had the atlas correctly, but the filename for the atlas seems to be case sensitive.


I changed the following and worked like a charm since:


BattleAtlas index was battleAtlas with lower case "b", once i changed it to capital "B" it worked fine.


 * Icons set atlases. Path relative to res_mods/x.x.x/gui/flash/atlases. DEFAULT XVM
 * Атласы с набором иконок. Пути относительно res_mods/x.x.x/gui/flash/atlases.
  "iconset": {
    // Path to the atlas with icons for the battle loading screen.
    // Путь к атласу с иконками для экрана загрузки боя.
    "battleLoadingLeftAtlas": "BattleAtlas",
    "battleLoadingRightAtlas": "BattleAtlas",
    // Path to the atlas with icons for the players panels.
    // Путь к атласу с иконками для "ушей".
    "playersPanelLeftAtlas": "BattleAtlas",
    "playersPanelRightAtlas": "BattleAtlas",
    // Path to the atlas with icons for the full stats form (on "Tab" key pressed).
    // Путь к атласу с иконками для формы подробной статистики (при нажатии клавиши "Tab").
    "fullStatsLeftAtlas": "BattleAtlas",
    "fullStatsRightAtlas": "BattleAtlas",
    // Path to the atlas with icons for the over-target markers.
    // Путь к атласу с иконками для маркеров над танками.
    "vehicleMarkerAllyAtlas": "vehicleMarkerAtlas",
    "vehicleMarkerEnemyAtlas": "vehicleMarkerAtlas"


Sorry if i messed you, i tried to make it as simple as possible and attached the whole content of the iconset.xc file in case someone is too lazy to change the letters :)

Link to comment

Out of curiosity i had to check my config and atlases.
Didn't even noticed upper case "B" on my atlases, but somehow it works just fine ingame, even my BattleAtlasEnemy. What? :astonished:

Games default (res\packages\gui.pkg\gui\flash\atlases\) and xvm default (iconset.xc) is battleAtlas.dds

However i did noticed that TIM (b161) saves as BattleAtlases.xxx and vehicleMarkerAtlas.xxx ...makes no sense. :smirk:

Link to comment

I'm using windows 10 pro. It worked for me fine as well till 1.5 update . After that they just didn't show up although all files were in place. No matter which contour icons of yours i was using, they weren't showing except from default. Curiously enough, it worked by just changing the first letter of index from lowercase to uppercase. That was the reason i did this post, as i tried re-installing WoT and didn't work either. If i have the same problem on next upgrade i'll have all the logs attached in case there is a bug or something on certain machines only.

Link to comment
1 hour ago, Raymius said:

Still not working in Version #03

Using windows 10?

This issue makes no sense in the first place, anyway with #03 atlases use lowercase b, shouldn't be an issue anymore.

Still, post your logs

Link to comment

I didn't have any issues since. #3 Installed and working like a charm, everything installed correctly and working. Your problem should be either on missing files or installed something that can't co-exist with the icons.


Gonna update the client and modpack today to see if it's still working, but i don't think anything have changed since these are micro-patches.

Edited by daltongr
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.