Jump to content

unable to select ships in port and having to exit game after battle

Recommended Posts

I have played in safe mode without any of the following issues:

Unable to select a ship in port.

Unable to exit game after battle is over.

Unable to crtl click on the mini map.

Issues while in Division on selecting a ship.


I am running mod pack I have tried unsuccessfully to go thru each mod I have installed to find what mod is causing my issues. No joy. I have even used the uninstall feature of the mod pack to remove mods and reinstall the mod pack.



Any thing else is needed let me know.




Link to comment

Did you remove all the mods and add one at a time back in until you found your problem?  It is hard to figure out the exact problem if you only remove one, but leave all the rest installed.  Also, All the logs I have looked at coming from users with problems have the Over Target Markers by BADoBEST installed.  I wonder if there is an issue with that mod or a conflict between that mod and another.


Link to comment

       I tried that, it was hit and miss. Right now I am running without mods and for some reason now I Can no longer ctrl click the mini map. I did have the over target but like I said I started from the bottom of the list and worked my way to the top removing mods logging in and out of the game to do so. I am to the point right now to re-download the WG WOWS client and reinstall. I do miss my  fog being removed as I have bad eye sight now..Getting old takes it's toll

Link to comment

Fog remover is a must for me as well for the same reasons and I have been running it without problems.


Before you try re-downloading the entire game, have you uninstalled the ModPack using Windows uninstall programs feature? Or run the game in "safe mode"?

Link to comment
I have the same problem since upgrade to the latest version of mod ..
- After several battles not let me select other ships .
- Let me not mark on the minimap.
- I have to leave the game to get it working again , but in a couple of games back again.
I uninstalled the mod several times , I've cleared the cache of the game and then I went back to 
install and continues to failure.. 
(sry for my english) Regards..


Edited by El_Gran_Capitan
Link to comment

Hello there,


exactly same issues version :  Aslains_WoWs_ModPack_Installer_v.


  • Unable to select a ship in port (caroussel unclickable).
  • Unable to exit game after battle is over (except with Escape).
  • Unable to crtl click on the mini map.
  • Chat in battle : no cursor focus on chat box with Enter => you don't know if you are writing something or not until a new Enter key.
  • Unable to open Combat log,






Got these issues from v. to  v.



Edited by Grimsek
Link to comment

Same goes for me. After a few games, i cannot select ship in port. And in game Ctrl+Ping becomes irresponive.


For all of those who have to relaunch the game, just hit Alt+Enter and enjoy the ship selections :P

Problem seems to be at full screen mode.


Also the in game timer remains, and most of the gui is lost in game.

Screenshot and logs attached.



Lost UI.png


Link to comment

@Grimsek I am starting to suspect there is an issue with either the gun marker mods or the Yet Another Zoom out mod.  Try removing those two mods and see if you still have the problems.  If so, we can try be removing some others until the problem goes away.  If the problem is gone, add one back in and play for a while to see if the problem comes back before adding the other one. 



@mavericksamaYou don't run very many mods, but other people having issues are also running the Players Panel mods.  Try removing that one.  If the problem still exists, also remove Trap sense.  I run the rest of the mods you use and don't have any issues with them.  If the problem goes away after you remove Trap sense, try adding your player panel mod back in.

Link to comment
3 hours ago, satto said:

i had the same. uninstall everything that have impact on  hud_lib.swf, for example trap sense or blueman icons

autospy minimap can casue the same error, so i switched to fugetsu


This seems to have fixed things.


No more general Akhbar :(


Thanks for the help BlueKq and satto.

Edited by mavericksama
Link to comment


I tried the download " - eu mirror # 2" and so far worked quite well , I have not had any problems that I 
mentioned in a previous post .. have if the of "eu mirror # 1" is bad .. hope that after posting this not 
begins to fail again  thanks and sorry for the post , greetings.. Good Job .. 
Link to comment
2 hours ago, mavericksama said:

Thanks for the help BlueKq and satto.

 You're welcome.. thanks for following our advice.  I can't keep up with testing every mod combination that people install to figure out which mod/mods are the problems so you removing some until you find the bad one helps us.

I just sent a message to Aslain so he can investigate or disable it until the mod author updates the mod.


I know "black citadel" was updated after the patch and works for me.  Maybe all the others that  mod hud_lib.swf need an update.????

Link to comment

    Today I ran a file from WG called WGcheck. Still Awaiting a full response back from WG regarding some issues I have based on the log file that was generated by WGcheck. The WGCheck stated that I have Extraneous files loaded with the game client. WG is pointing to a mod that I was using and I am disputing that as I removed all components of the mod pack I had. Typical of WG to lay blame else where than at themselves. Until what ever crashed my game can be figured out I am mod-less and stuck in safe mod. Right now WG is not recommending reinstall of the client for WOWS because I may lose my ingame ships that were rewarded along with my Premium ships and doubloons. So until I hear back from WG. I am in a holding pattern regarding what is in the log file that WGcheck generated.


  I have as of this date removed all the Aslain mod pack files. I ran the Windows uninstall under control panel,  my DLC cache has been purged and deleted also. I even ran the uninstall.exe that came with the mod pack. The windows control panel uninstall did not remove all the files. I manually had to remove the rest. No worries I will get this fixed and be back to using the mods I like.


Thank you to all that have posted in this post.



P.S. has anyone looked over my log files in prior post to see if there is and issue there? Just a thought.

Link to comment
3 hours ago, Seabee said:

P.S. has anyone looked over my log files in prior post to see if there is and issue there? Just a thought.


Did you try what I suggested right after your first post and run the ModPack installer removing mods until the problem did not exist?  Is this most recent post telling me that you did that and there are still problems that are only resolved running in safe mode?


If you read my post, many players that run the BADoBEST HP+Nick are reporting problems.  Other people have found that the Sixth Sense and Trap Sense were causing their problems, leading me to believe that the hud_lib.swf file was changed by WG and any mod that changes that will need to be updated.


Lastly, you should not lose any premium ships or doubloons by reinstalling the game.. You can verify that by installing it on a different computer or a in a different directory during the install process.  When you log in, all your stuff will be there because your account details are stored on the WG servers.  I play from multiple computers and have never had items missing when I played on a different computer.

Link to comment

    Thanks BlueKQ for your responses. Yes I tried the suggestions you recommended. By removing one Mod at a time.(EDIT: I do believe that during the issues with the mods that some how after game update and patch that one of my game files corrupted only compounding my issues ) It was at the that time these issues started.  I was using the  mods you listed; Trap Sense, BADoBEST HP+Nick, Fog remover, Hakabase Ship icons and several others. According to WG I have a corrupted  file they are not sure what file it is exactly The WGcheck keeps showing that I have a damaged file system even after it self repairs. Here is the latest response I received from WG:


Hey there jwar41,

Thanks for getting back to us. I'm afraid that the issue you've been seeing is a known issue and there are other players reporting this issue.

Please keep an eye on our patch notes to see if this bug is corrected in a specific patch.

We shall contact you for additional information, if needed, and we sincerely appreciate your interest in the improvement of World of Warships.

Please do not hesitate to contact us if you have any further questions or concerns.

Good luck and fair seas!

Best Regards,

Jammie Berge

Wargaming.Net Support

Wargaming America Support



I will most likely just reinstall the game and reinstall the Aslain mod pack after the new install. Thanks for the suggestion of installing the Game Client on another PC I will try that before I purge it from this system. To all WOWS Captains Fair Seas and Trailing Winds. See you on the open seas.


Again thank you to all whom have responded.

Edited by Seabee
Link to comment

I continue to have the same problems noted above by others as well. I just downloaded the mod pack and am installing one item at a time starting from the bottom, playing a couple games to see what happens then installing the next item up. So far I have Smoke Screen Boundaries, yellow torpedoes in water by Pturbo, six sense custom damage indicator & torpedo markers and Salty ship commanders for USA installed with no problems. I will continue going up the line one by one to try to nail down the problem. I am also playing the 0.5.8 public test so it may take a couple days for me to get through them all but I will make another post here when I get to it with the results.

Edited by MrExNavy
Link to comment

    I had to reinstall the WOWS client. There was a damaged file in the Hub_lib.swf. The WGCheck kept finding the error and could not repair( Although WG wanted me to wait until the patch).  I uninstalled the client and reinstalled.

      Every thing is vanilla at the moment no mods. Only issue I see in game now is the ARP Kongo not having a hull researched. Mini map is working again. So I am happy disappointed in WG for having bad code but we can not have it all sometimes.


  Now onto mods. Just downloaded the mod pack will see what happens from there. I will get in touch with MrExNavy since we game together on a regular basis. To see what progress he has made. Until then everyone take care.



Again a huge thanks BlueKQ you have been a great help. So Thanks Seabee AKA jwar41

Link to comment

Can everyone that's been testing mods confirm what are safe to use? Just had the same problem as OP again. It looks Admiral Ackbar is saying bye for now (liked that trap sense).


If need be, I'll list the mods I'm currently running.

Link to comment

It is nearly impossible to list every combination of mods that are working.  Please follow the instructions in the post linked in this reply describing how to upload the ModPack logs.  Thjat is what will help us to help you.



Link to comment
  • Administrator
3 hours ago, Reymu said:

Can everyone that's been testing mods confirm what are safe to use? Just had the same problem as OP again. It looks Admiral Ackbar is saying bye for now (liked that trap sense).


If need be, I'll list the mods I'm currently running.


6th sense mods are updated in latest modpack, so why would you have to let it go? ;)

Link to comment

Guys when this happens what is happening is your cursor is misaligning. People think they cant exit battles unless they hit escape, they can`t type in cha unless they press tab etc.


I ran a test and it is simply the cursor being 40 pixels-120 pixels south of where it is aim at. But ingame the crosshairs take over and force alignment.


IF THESE PROBLEMS HAPPEN AGAIN DO NOT UNINSTALL GAME. OMG everytime I read a person jumping to that right away I cringe, your just slowing down he server for us :)


There is a way to do a sanity check so if your game has files that are corrupted or missing it just replaces those, I will do a post on it later. And if it hangs on the file like the HuD_Lib.swf then delete the current one and it will force DL a new one.


If the problem happens again guys it is the HUD_LIB.SWF and this file contrils ALL THE RIBBONS, and logo`s and signs in game. It also aligns your cursor image.


Please dont freak out and delete client, thats a huge waste of 10 gb`s of perfectly healthy files. This is hwy WG made RES_Mods so you could simply delete it and clear cahce and be done.

  • Upvote 2
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.