Jump to content
chokky69

Problem with XVM statistic

Recommended Posts

Aslain, I have problem with XVM statistic since I have installed version #07. In version #05 I have no such problems

Problems is that there is no XVM player statistic in any of panels. shot_043.thumb.jpg.99aabc27c0b17636baa3f78e6d8dd326.jpg

 

Here is my log files.

I regularly update XVM statistics and doesn't change any setings during installing your mod pack (between #05 and #07).

 

 

 

 

 

Aslains_WoT_Logs.zip

Share this post


Link to post
Share on other sites

Your xvm token/service appears active, aside from empty python and bit off xvm log (9105?)

2019-06-02 19:18:25:     XVM Version   : 7.9.3
2019-06-02 19:18:25:     XVM Revision  : 9105
2019-06-02 20:00:09: [B:004] [XVM INFO]
                               XVM_VERSION=7.9.3 #9105 for WoT 1.5.0.4
                               gameRegion=EU
                               configVersion=6.1.0
                               autoReloadConfig=false
                               markers.enabled=true
                               servicesActive=true
                               xmqp=false
                               statBattle=true

You might wanna play game or 2 and post new logs.
Did you try reseting all tokens on xvm site and activating xvm again?

Share this post


Link to post
Share on other sites

Here is the new logs after one battle played with #07.

As I said before, version #05 works OK, I have problems with #07. Configuration is the same in both versions.

Aslains_WoT_Logs.zip

Share this post


Link to post
Share on other sites

"Configuration is the same in both versions." :expressionless:

If you say so...lets compare just in case.
#5 xvm 7.9.3 (9105)

2019-06-02 19:18:39: [INFO]    HTTPS: /4.0/getOnlineUsersCount/0
2019-06-02 19:18:41: [INFO]    Time: 1372 ms, Size: 666 (666) bytes
2019-06-02 19:19:18: [INFO]    HTTPS: /4.0/getToken/c99d11f9-****-****-****-********ef10/516173316
2019-06-02 19:19:18: [INFO]    Time: 310 ms, Size: 303 (303) bytes
2019-06-02 19:19:18: [INFO]    HTTPS: /4.0/getVersionWithLimit/c99d11f9-****-****-****-********ef10/516173316/0/50
2019-06-02 19:19:19: [INFO]    Time: 303 ms, Size: 5637 (5637) bytesr
2019-06-02 19:19:26: [INFO]    HTTPS: /4.0/getStatsByNick/c99d11f9-****-****-****-********ef10/EU/Chokky69
2019-06-02 19:19:26: [INFO]    Time: 545 ms, Size: 20224 (20224) bytes
2019-06-02 20:00:08: [INFO]    HTTPS: /4.0/getStats/c99d11f9-****-****-****-********ef10/527463379=61249,551343205=7217,500487014=61249,502766702=5393,527923823=14145,525536757=60689,545621626=257,514445179=61249,551347069=61249,514089599=61249,516173316=61249=1,562287109=18193,501724937=61249,512547597=61249,500901007=60689,504960785=60689,523936915=61249,549209876=61249,515007254=61249,511039899=61249,535084956=18193,558736168=61249,500205747=61249,527538953=2897,515201598=60689,522688757=61249,561520960=61249,500918468=61249,510293447=61249,527450962=61249
2019-06-02 20:00:09: [B:004] [XVM INFO]
                               XVM_VERSION=7.9.3 #9105 for WoT 1.5.0.4
                               gameRegion=EU
                               configVersion=6.1.0
                               autoReloadConfig=false
                               markers.enabled=true
                               servicesActive=true
                               xmqp=false
                               statBattle=true

#7 xvm 7.9.4 (9116)

2019-06-02 22:58:20: [INFO]    HTTPS: /4.0/getOnlineUsersCount/0
2019-06-02 22:58:20: [ERROR] loadUrl failed: nested asn1 error (_ssl.c:2946)  File "res_mods/mods/xfw_packages\xvm_main\python\loadurl.py", line 88, in _loadUrl
2019-06-02 22:59:27: [INFO]    HTTPS: /4.0/getToken/c99d11f9-****-****-****-********ef10/516173316
2019-06-02 22:59:27: [ERROR] loadUrl failed: nested asn1 error (_ssl.c:2946)  File "res_mods/mods/xfw_packages\xvm_main\python\loadurl.py", line 88, in _loadUrl
2019-06-02 22:59:27: [INFO]    HTTPS: /4.0/getVersionWithLimit/c99d11f9-****-****-****-********ef10/516173316/0/50
2019-06-02 22:59:27: [ERROR] loadUrl failed: nested asn1 error (_ssl.c:2946)  File "res_mods/mods/xfw_packages\xvm_main\python\loadurl.py", line 88, in _loadUrl
2019-06-02 22:59:32: [INFO]    HTTPS: /4.0/getStatsByNick/c99d11f9-****-****-****-********ef10/EU/Chokky69
2019-06-02 22:59:32: [ERROR] loadUrl failed: nested asn1 error (_ssl.c:2946)  File "res_mods/mods/xfw_packages\xvm_main\python\loadurl.py", line 88, in _loadUrl
2019-06-02 23:01:30: [INFO]    HTTPS: /4.0/getStats/c99d11f9-****-****-****-********ef10/560251393=58113,558294146=61249,510042243=273,525419012=10529,503808861=801,508748824=16417,526476356=5633,506202906=61249,549389725=58113,500833055=1137,543512225=61249,543779106=1041,556273839=257,502049978=61249,500016319=1105,507722948=3457,500075336=1,527463379=61249,557524309=2561,529367131=273,508450013=5649,515924066=10529,503850469=7217,516173316=61249=1,531730672=2561,562667091=10529,500346741=5649,505699062=10497,514673528=61249,500809212=15889
2019-06-02 23:01:30: [ERROR] loadUrl failed: nested asn1 error (_ssl.c:2946)  File "res_mods/mods/xfw_packages\xvm_main\python\loadurl.py", line 88, in _loadUrl
2019-06-02 23:01:30: [ERROR] Stat request data is None
2019-06-02 23:01:31: [B:004] [XVM INFO]
                               XVM_VERSION=7.9.4 #9116 for WoT 1.5.0.4
                               gameRegion=EU
                               configVersion=6.1.0
                               autoReloadConfig=false
                               markers.enabled=true
                               servicesActive=true
                               xmqp=false
                               statBattle=true

python

2019-06-02 22:58:20.870: NOTICE: [NOTE] (scripts/common/debug_utils.py, 251): User authentication method: token2
2019-06-02 22:58:28.819: ERROR: Exception in thread Analytics-29:
2019-06-02 22:58:28.819: ERROR: Traceback (most recent call last):
2019-06-02 22:58:28.819: ERROR:   File "scripts/common/Lib/threading.py", line 810, in __bootstrap_inner
2019-06-02 22:58:28.819: ERROR:   File "scripts/common/Lib/threading.py", line 763, in run
2019-06-02 22:58:28.819: ERROR:   File "scripts/client/PYmodsCore/utils.py", line 198, in analytics_start
2019-06-02 22:58:28.819: ERROR:   File "./src/cpython_python/urllib2.py", line 154, in urlopen
2019-06-02 22:58:28.820: ERROR:   File "./src/cpython_python/urllib2.py", line 429, in open
2019-06-02 22:58:28.820: ERROR:   File "./src/cpython_python/urllib2.py", line 447, in _open
2019-06-02 22:58:28.820: ERROR:   File "./src/cpython_python/urllib2.py", line 407, in _call_chain
2019-06-02 22:58:28.820: ERROR:   File "./src/cpython_python/urllib2.py", line 1241, in https_open
2019-06-02 22:58:28.820: ERROR:   File "./src/cpython_python/urllib2.py", line 1167, in do_open
2019-06-02 22:58:28.820: ERROR:   File "./src/cpython_python/httplib.py", line 1247, in __init__
2019-06-02 22:58:28.820: ERROR:   File "./src/cpython_python/ssl.py", line 445, in create_default_context
2019-06-02 22:58:28.820: ERROR:   File "./src/cpython_python/ssl.py", line 412, in load_default_certs
2019-06-02 22:58:28.820: ERROR:   File "./src/cpython_python/ssl.py", line 404, in _load_windows_store_certs
2019-06-02 22:58:28.820: ERROR: SSLError: nested asn1 error (_ssl.c:2946)
2019-06-02 22:58:28.820: ERROR: 
2019-06-02 23:07:56.748: ERROR: [EXCEPTION] (scripts/common/Event.py, 89):
Traceback (most recent call last):
  File "scripts/common/Event.py", line 87, in __call__
  File "scripts/client/PYmodsCore/utils.py", line 218, in end
  File "./src/cpython_python/urllib2.py", line 154, in urlopen
  File "./src/cpython_python/urllib2.py", line 429, in open
  File "./src/cpython_python/urllib2.py", line 447, in _open
  File "./src/cpython_python/urllib2.py", line 407, in _call_chain
  File "./src/cpython_python/urllib2.py", line 1241, in https_open
  File "./src/cpython_python/urllib2.py", line 1167, in do_open
  File "./src/cpython_python/httplib.py", line 1247, in __init__
  File "./src/cpython_python/ssl.py", line 445, in create_default_context
  File "./src/cpython_python/ssl.py", line 412, in load_default_certs
  File "./src/cpython_python/ssl.py", line 404, in _load_windows_store_certs
SSLError: nested asn1 error (_ssl.c:2946)

(ignoring possible token corruption, xvm 7.9.4 changes and mutliple #5/#7 reinstalls)

Looks the "same" to me, must be the modpack or xvm issue... right? :expressionless:
If so, wait for modpack with newer 7136+ xvm.

Share this post


Link to post
Share on other sites

I have exact sam problem.

 

With the same error

 

  modxvm.com - XVM 7.9.4 (9136)

Mrežna usluga nedostupna.  više detalja

nested asn1 error (_ssl.c:2946)

Share this post


Link to post
Share on other sites

Check yout antivir or router, maybe something blocking the access to xvm server.

Share this post


Link to post
Share on other sites

Whatever it is, it's on your computer. I have all stats, when using same mods like you have installed.

Share this post


Link to post
Share on other sites

Never mind, I'll use #05. I don't believe that is something wrong with my comp because #05 works and #07 or #08 doesn't, with same game installation setup.

Share this post


Link to post
Share on other sites

I'm not saying your computer is broken but something on it is preventing xvm stats to work properly. It's probably related to new XVM version (most likely due to that changes in networking https://bitbucket.org/XVM/xvm/commits/48396eeea4ca3465a4e6ebb27624d69c76ce326a). If I were you I would try to sort it out asap, because you will have big problem later with 1.5.1.0 (around 12th June), when old XVM (from #05) stop to work.

 

Delete res_mods and mods, and try https://dl1.modxvm.com/bin/xvm-7.9.4.zip (unpack to game root directory), if you still have no stats, then report it to https://koreanrandom.com/forum/forum/43-xvm-extended-visualization-mod/

 

It's also worth to delete xvm tokens before you try anything.

Share this post


Link to post
Share on other sites

" It's also worth to delete xvm tokens before you try anything. "

How to do that?

I've also noted that few new lines in ChangeLog-en.txt but not understand what I should do about it :-(

Share this post


Link to post
Share on other sites

step1... go to https://modxvm.com/en/ your settings and reset/delete all active tokens

xvmtoken.thumb.png.095f2e21fee63e589faa872045c872ef.png

step2... (assuming you are using windows) press Windows key+R, type %appdata% and open it
go inside ...Roaming\Wargaming.net\WorldOfTanks\xvm and delete tokens folder

step3... start wot and activate your xvm again, then restart wot
Congratz you managed to delete/reset your tokens.

...only after you do those 3 steps and still have issues, then post new logs.

EDIT:Nothing misterious if your xvm token is corrupted (until you test it and confirm it's not).

Share this post


Link to post
Share on other sites

So reverting XVM native wotmod to an older version fixed it for you. I'm wondering if they release new XVM soon with proper fix soon or it's more work for them.

Share this post


Link to post
Share on other sites

With the temporary finx of XVM in Aslain's WoT ModPack v1.5.0.4 #10 now everything works OK once again.

Share this post


Link to post
Share on other sites

As the title says, player stats and win chance no longer showing during game play. Have used Aslain's xvm for about 2 weeks now and this started just 2 days ago. I have since down loaded the most recent update, but still nothing shows during game play.
Any suggestions?

Share this post


Link to post
Share on other sites
On 6/3/2019 at 5:38 PM, Ress said:

step1... go to https://modxvm.com/en/ your settings and reset/delete all active tokens

xvmtoken.thumb.png.095f2e21fee63e589faa872045c872ef.png

step2... (assuming you are using windows) press Windows key+R, type %appdata% and open it
go inside ...Roaming\Wargaming.net\WorldOfTanks\xvm and delete tokens folder

step3... start wot and activate your xvm again, then restart wot
Congratz you managed to delete/reset your tokens.

...only after you do those 3 steps and still have issues, then post new logs.

EDIT:Nothing misterious if your xvm token is corrupted (until you test it and confirm it's not).

Thanks! This fixed the problem on my system. If the OP follows your instructions, I think it should work for him too, as I was experiencing the exact issue he reported.

  • Like 1

Share this post


Link to post
Share on other sites

You should have post logs, it's mandatory with every bug report. Go to xvm website and reset token.

Share this post


Link to post
Share on other sites

Same problem again! But it si OK when I applied you fix for XVM. So please, include your fix for XVM from previous version

Share this post


Link to post
Share on other sites

I cannot at this time, I will not use files from the old game client :( That's why I said it's important to sort it out before the game will be updated. Looks like they are not good with fixing that issue....

 

  • Upvote 1

Share this post


Link to post
Share on other sites
1 hour ago, chokky69 said:

Same problem again! But it si OK when I applied you fix for XVM. So please, include your fix for XVM from previous version

You are better of trying to figure out why you have issues with latest xvm builds then trying to use old 1.5.0.4 stuff. :confused:

That "fix" was temporary fix - use of part from previous xvm 7.9.3 version inside 7.9.4 and we are now on xvm 7.9.5 + new wot patch.
You can't use older parts from previous xvm builds forever and hope to just work without issues with future game patches.

Aslain warn you about this and here we are 1.5.1.0 and you can't use old "fix" anymore. :confused:

EDIT: Of course you can but should you use it is the question...

Share this post


Link to post
Share on other sites

I can use this file "com.modxvm.xfw.native_1.4.3.00085.wotmod" from old XVM and everything is OK. I'll use it as long as possible!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.