Jump to content

Trouble downloading latest Install Pack - now requires Open Download Manager?

Recommended Posts

Ever since that last few updates of the Aslain Mod Pack Installer for 9.14 (WOT), and now for 9.15, I can't get a download to start - since the requirement to use Open Download Manager. I've tried several several times to download and a screen pops up to get Open Download Manager.  I download and run Setup_ODM which seems to install, but then nothing. I can't find it anywhere as an installed program. And when I try to download the Aslain Mod Pack Install again it goes through the same routine; download ODM, run setup, and.....nothing.

What's the trick to get the Mod Pack Installer?  Am I forced to use ODM?  Why won't it work?  I'm on Windows 7.  The last Mod Pack I've got loaded is 9.14.41.

Thanks for any help on getting the latest Mod Pack.

Link to comment
  • Moderator

There's no requirement to use Open Download Manager... what link are you using?...

There are four links:

1 is adfly to Mediafire download

1 is adfly to torrent download

1 is direct torrent download

1 is direct Mediafire download


Edit to add links related to ODM:



Edited by Quaksen
Link to comment

I always used the first one - adfly to Mediafire download.  That's when the screen to download ODM pops up.  I just did the 'direct Mediafire' and got the modpack to download. I've never had to download using that link, but I guess I will from now on. Thanks.

Link to comment
  • Moderator

Just tried the adfly link, nothing about ODM showed.

The ad page was a little fishy though, since it asked to enter mobile phone number to download contents. LOL.

But adfly has always been a bit fishy in my experience - but there's always that big SKIP button in the top right corner, which is the only thing one should ever click on an adfly link :)

Link to comment

Yeah, I'm getting this issue too. I'm being told to disable Ad Block first, which I do for the page, then I'm told to update my flash player (which it is) 01 second before I can skip the ad, and when I've finally found a way to hit the "skip ad", the link fails and opens a new page to a bogus scam page instead of the download page. I use only your main page link. I've never clicked any ad. I don't know what to say...


On top of that, my current WoT client fails about 90% into the loading screen. I can't ALT+TAB out, or I get a black screen with only my bottom task bar visible. I can't open or close any tasks though, but I can restart my computer.


Kudos on all the hard work you put into these mods, BTW. Been a fan for a couple years now. You're always quick on the updates and new mods are always appreciated. Keep up the good work!

  • Upvote 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.